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Abstract 

This tutorial provides users with a step-by-step guide to performing an 
analysis with ProAnalyst 3-D Professional Edition. This lesson covers the 
ProAnalyst 3-D Manager, calibration, measurement, and graphing. Prior 
ProAnalyst experience is assumed, but not required. Where necessary, 
we refer to other tutorials that explain concepts not included in the scope 
of this document. 

 

Files Needed for This Tutorial  

Click here to download these files. 

Robot1.avi  

Robot2.avi  

Cal1_0.jpg  

Cal2_0.jpg  

Robot1.cfg 

Robot2.cfg 

TestFixture.fixt  
 

 

http://www.xcitex.com/Resource%20Center/ProAnalyst/Tutorials/T113%20-%20Video%20files.zip
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Setting Up a Project for 3-D Analysis 

1. Copy the TestFixture.fixt file into your Program Files\Xcitex\ProAnalyst\Fixtures directory or 
another location where you have installed ProAnalyst on your computer. 

 
Note: If you are using a Network licensed edition, create a new folder on your hard drive and 
place the file in it. You will need to browse to this file location later. 

2. Launch ProAnalyst and create a new project by selecting File > New Project. Right-click the 
empty project window and select Project > Add Video(s). Double-click to add the Cal1_0.jpg file 
to the project. Repeat the process to add the Cal2_0.jpg, Robot1.avi, and Robot2.avi files to the 
project. Save the project and give it a title. 

Note: For more information on working with projects, please refer to ProAnalyst Tutorial 100: 
Learning to Use ProAnalyst.  

3. Create a new 3-D Manager by selecting Tools > New 3-D Manager. 

4. Click on the title bar of the Cal1_0.jpg window, then drag and drop the Cal1_0.jpg file from the 
project onto the Calibration 1 panel on the 3-D Manager. Repeat the process to drag Cal2_0.jpg 
onto the Calibration 2 panel, Robot1.avi onto the Measurement 1 panel, and Robot2.avi onto the 
Measurement 2 panel. 

 

 

Figure 1. Project and 3-D Manager windows 
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5. Each time you drop an image or video onto the appropriate panel, the video will open in a new 
measurement window and immediately minimize to a position on the bottom of the screen. 
Double-clicking on one of the panels expands the minimized video to full size for processing or 
analysis. After adding the calibration and measurement videos to the 3-D manager, click the 
Save button and give the 3-D manager file a name. You can now add the 3-D manager to your 
project file in the same way that you would add a video source by right-clicking on the project 
window and selecting your newly created 3-D manager. 

 

3-D Calibration 
 

1. Click the Calibration tab on the left side of the 3-D Manager window or the Calibration icon  
on the right side of the window. The 3-D Calibration window is displayed. Figure 2 shows the 3-D 
Calibration window with the tab and icon circled. 

 

 

 

Figure 2. 3-D Calibration window 
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2. From the Standard Fixture dropdown menu select the Model VC4: #400x fixture file. This list 
includes the files in your default program directory. 
 
 
Note: If you are using a network licensed edition of ProAnalyst, click Load Fixture from File and 
browse to the location on your local hard drive where you saved the file in Step 1. 
 
 

 

Figure 3. Standard Fixture menu 

 

3. A dialog box will appear indicating that the fixture points have loaded successfully. Click OK. The 
Calibration Points window is displayed. You may close this window without modifying any of the 
data. 
 

4. Click the Define First Region button. A message appears prompting you to click on the 6 
corners of the region that you wish to select. Start at the lower left corner, and click six points 
counter clockwise around the perimeter of the top calibration fixture image. Make sure that the 
region encompasses all of the points on the fixture, and that the points are clicked in the order 
shown in Figure 4. 
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Figure 4. Point definition for first and second regions 

 

5. Click the Define Second Region button. Again, a message prompts you to select the six corners 
of the region. Repeat the process for the bottom fixture image, clicking on the same points in the 
same order.  

Note: You can right-click on either of the calibration images and select one of the Locate Point 

Settings (TOP) or (BOTTOM) options from the pop-up menu. The Locate Point Settings dialog 

box appears as shown in Figure 5. Changes in lighting, resolution, field of view, and other factors 

alter the appearance of the fixture. A number of parameters may be adjusted in order to 

compensate for these changes. The Locate Point settings control how the image is processed 

and how the points are identified from the processed image. For more information on this feature, 

refer to the 3-D Calibration section of the ProAnalyst User Guide. For this tutorial, you may leave 

the settings at their default values and click OK. 
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Figure 5. Locate Point Settings dialog box 

 

6. Click the Locate button on the 3-D Calibration panel and select Both Top and Bottom from the 
popup menu. Another popup displays a status bar as the fixture points are located within the 
images. After the defined regions are processed, the dialog box shown in Figure 6 appears. Click 
the Yes button to continue.  
 

 

Figure 6. Operation Completed dialog box 

 

Note: Once the fixture points have been successfully located, you may click the Align button and 

select Both Top and Bottom to correct any misalignments that may have resulted from the 

automatic detection process. Alignment places all the points on straight lines to improve the 

accuracy of the calibration. The Operation Completed dialog box appears again. Click Yes. (This 

step is optional for this tutorial.) 

If errors occur as the regions are processed, you may see the dialog box shown in Figure 7. You 

may need to redefine the search regions on the calibration images and/or modify the values in the 

Locate Point Settings menus. If the search region is too large, the software may pick extraneous 

black dots as fixture points. 
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Figure 7. Error Locating Fixture Points dialog box 

 

7. Click the Calibrate button on the 3-D Calibration panel. ProAnalyst will now determine the 
positions of the two cameras, and create the 3-D world space for the analysis. 
 

8. After you calibrate, a Calibration Completed dialog box will be displayed as shown in Figure 8. 
This dialog will show the Mean Error, Standard Deviation, Minimum Error, and Maximum Error 
inherent in your calibration. If you are satisfied with the results, click OK. If you would like to try to 
reduce any calibration error, you may repeat any or all of the previous steps and click the 
Calibrate button again to see the new calibration settings. 

 

 

Figure 8. Calibration Completed dialog box 
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9. Next, click the Graph Points button on the 3-D Calibration panel to display a 3-Axis plot of the 
fixture. The blue spheres displayed on the plot represent the positions of your cameras relative to 
the fixture.  

 

 

Figure 9. 3-Axis Plot 

 

 

  



 
Quantifying Motion in Three Dimensions with ProAnalyst

®
 

 
 

 
© Copyright 2015 Xcitex Inc. All rights reserved. Page 9 Document 113, Rev. 2 

 

3-D Measurement 

After calibration, the next step is tracking the features you wish to analyze. Standard 2-D tracking tools 

are used on both videos of the event, the results of which are then transformed into 3-D space by 

ProAnalyst. 

1. When you added the Robot1.avi and Robot2.avi videos to the 3-D Manager, the videos 
automatically opened in their own Measurement windows, which then minimized at the bottom of 
the screen. Restore the Robot1.avi Measurement window, and open the Feature Tracking panel 
by clicking the 2-D icon at the right side of the screen. Next, click the Enable button to begin 
defining the features to track. 
 

2. Click Define Region. Position the reticle and draw a box around the robot’s belt buckle. Click Set 
Region to set the belt buckle as Feature 1. Next, click the Add button to add Feature 2. Repeat 
the previous steps to define and set regions for three features on the robot’s body. The Define 
Region, Set Region, and Add buttons are shown circled in Figure 10. 
 
 

 
 

Figure 10. Feature Tracking panel 
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3. After all three features have been defined as shown in Figure 11, click the Track Forward button 
 to see the movement of the features. 

 
4. Click Save and then click Save in the dialog box to save the tracking file as Robot1.ftk. Click OK 

when the message Analysis saved successfully to file appears. Minimize the Robot1.avi 
window.  

Note: For more information on feature tracking, please refer to ProAnalyst Tutorial 100: Learning 

to Use ProAnalyst and ProAnalyst Tutorial 112: Tracking a Rotating Object. Both documents are 

available at http://www.xcitex.com. 

 

 

Figure 11. Robot with features defined 

 

5. Restore the Robot2.avi Measurement window, click the 2-D icon, and repeat the previous steps 
to track and save the same three features on the robot. When defining features in Robot2.avi, be 
certain that the features correspond to the same features in Robot1.avi (for example, Feature 1 is 
the belt buckle in both videos). Save the tracking file as Robot2.ftk and minimize the Robot2.avi 
window. 
 

  

http://www.xcitex.com/
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6. After the identical features have been tracked on both videos, restore the 3-D Manager and click 
the Measurement tab on the left side of the window. 
 
 

 

Figure 12. 3-D Measurement panel 

 

7. Click the Add Matching button (shown circled in Figure 12) to populate the 2-D Data Sources list 
with the tracked features from Robot1.avi and Robot2.avi. 

Note: Add Matching will pair up tracked features based on the feature number in the 

Measurement Window Feature Tracking list. For this reason, it is necessary for the features 

tracked in Robot1.avi and Robot2.avi to match. If the feature numbers in a pair of videos do not 

match, feature pairs can be added manually by clicking the Add button and selecting each 

feature pair manually. 
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3-D Graphing  

1. After adding the tracked feature pairs to the 3-D Measurement panel, click the Graph Points 
button. A new 3-Axis graph will be created with the tracked features automatically added and 
displayed. 

 
 

 

Figure 13. 3-Axis graph of tracked features 
 

 
 

2. Click the Configure button located in the upper right corner of the graph window to open the Line 
Configuration window, shown in Figure 14. 
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Figure 14. Line Configuration window 

 
 
 
 

3. Now you can add and define a series of lines to connect the tracked points. Click Add Line and 
define the sequence of points in the line as shown in Figure 14.  
 

4. Click the Apply button, followed by the Close button. The displayed points will now be connected 
with lines. 3-D length and angle calculations are available for any line sequence. To display these 
measurements, click the appropriate check box for the sequence in the Line Configuration 
window before you click Apply and Close. 
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5. To make the plot easier to see, a number of options can be enabled within the graph window. 

Click the Graph Sources/Options  icon to open the 3-Axis Graph Sources/Options tool 

palette. Under Options, select Fixed from the Axes menu choice to open the Additional Graph 

Options window.  

 

 

Figure 15. 3-Axis Graph Sources/Options windows 

 

6. Click each Fixed #-Axis Bounds checkbox and the Get Current button associated with each 
axis. The values in the Minimum and Maximum value text boxes will update to reflect the 
bounding area of the plot. Click OK to close the window. 
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7. Finally, select Show Current from the Show Points dropdown list at the bottom of the window 
and press the  button at the bottom of the graph window to see the motion of the tracked 

features as shown in Figure 16. 

 

 

Figure 16. Motion of tracked features 
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Additional Practice 

After you have mastered the basics of 3-D tracking for the three features of the robot as described in this 

tutorial, try adding and tracking additional features for further practice. Figure 17 shows the graph of the 

robot with additional features tracked. 

 

 

Figure 17. 3-D graph of robot with additional tracked features 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

This tutorial is copyrighted by Xcitex Inc. and is supplied without specific warranty to any 

purpose and based on information currently available at the time of this writing. All 

specifications stated herein are subject to change without notice. 

ProAnalyst is a registered trademark of Xcitex Inc. All rights reserved. 

For further information on Xcitex products, visit www.xcitex.com or send an email to 

info@xcitex.com. 

 

Xcitex Inc.  

8 Cabot Road 

Suite 1400 

Woburn, MA 01801 USA 
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